[CMAKE] Remove obsolete 'CMAKE_CXX_COMPILER_VERSION' checks (#2981)
authorSerge Gautherie <32623169+SergeGautherie@users.noreply.github.com>
Sat, 18 Jul 2020 13:37:29 +0000 (15:37 +0200)
committerGitHub <noreply@github.com>
Sat, 18 Jul 2020 13:37:29 +0000 (15:37 +0200)
Following upgrade to RosBE 2.2.0 support and GCC 8.4.

base/applications/network/telnet/CMakeLists.txt
base/services/tftpd/CMakeLists.txt
dll/3rdparty/libxslt/CMakeLists.txt

index b0916c0..8e586fa 100644 (file)
@@ -3,7 +3,7 @@ set_cpp(WITH_EXCEPTIONS WITH_STL)
 
 add_definitions(-D_CRT_NONSTDC_NO_DEPRECATE)
 
-if(NOT MSVC AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 7.0)
+if(NOT MSVC)
     add_compile_flags("-Wno-restrict")
 endif()
 
index 0159e0e..f4bd0cb 100644 (file)
@@ -1,5 +1,5 @@
 
-if(NOT MSVC AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 7.0)
+if(NOT MSVC)
     add_compile_flags("-Wno-format-overflow")
 endif()
 
index 8105fdd..d5e2d3b 100644 (file)
@@ -1,5 +1,5 @@
 
-if(NOT MSVC AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 7.0)
+if(NOT MSVC)
     add_compile_flags("-Wno-misleading-indentation")
 endif()