Git conversion: Make reactos the root directory, move rosapps, rostests, wallpapers...
[reactos.git] / base / applications / charmap / CMakeLists.txt
diff --git a/base/applications/charmap/CMakeLists.txt b/base/applications/charmap/CMakeLists.txt
new file mode 100644 (file)
index 0000000..e576b74
--- /dev/null
@@ -0,0 +1,15 @@
+
+list(APPEND SOURCE
+    about.c
+    charmap.c
+    lrgcell.c
+    map.c
+    settings.c
+    precomp.h)
+
+add_rc_deps(charmap.rc ${CMAKE_CURRENT_SOURCE_DIR}/res/charmap.ico)
+add_executable(charmap ${SOURCE} charmap.rc)
+set_module_type(charmap win32gui UNICODE)
+add_importlibs(charmap advapi32 user32 gdi32 comctl32 msvcrt kernel32)
+add_pch(charmap precomp.h SOURCE)
+add_cd_file(TARGET charmap DESTINATION reactos/system32 FOR all)