* Sync with recent trunk (r52637).
[reactos.git] / base / applications / mstsc / CMakeLists.txt
index 1ee8699..ef0eb89 100644 (file)
@@ -23,10 +23,12 @@ list(APPEND SOURCE
     win32.c
     rdc.rc)
 
-add_executable(mstsc ${CMAKE_CURRENT_BINARY_DIR}/mstsc_precomp.h.gch ${SOURCE})
-
-add_pch(mstsc ${CMAKE_CURRENT_SOURCE_DIR}/precomp.h ${SOURCE})
+add_executable(mstsc ${SOURCE})
 
 set_module_type(mstsc win32gui)
 
-add_importlibs(mstsc user32 gdi32 comctl32 ws2_32 advapi32 shell32 ole32 comdlg32 msvcrt)
+add_importlibs(mstsc user32 gdi32 comctl32 ws2_32 advapi32 shell32 ole32 comdlg32 msvcrt kernel32)
+
+add_pch(mstsc precomp.h)
+
+add_cd_file(TARGET mstsc DESTINATION reactos/system32 FOR all)