[CMAKE]
[reactos.git] / base / applications / network / ftp / CMakeLists.txt
index 83b2ccf..0d74b9a 100644 (file)
@@ -1,4 +1,7 @@
-add_definitions(-D_DLL -D__USE_CRTIMP)
+
+add_definitions(
+    -D_DLL -D__USE_CRTIMP
+    -Dlint)
 
 add_executable(ftp
     cmds.c
@@ -11,11 +14,11 @@ add_executable(ftp
     ftp.rc)
 
 set_module_type(ftp win32cui)
-
 add_importlibs(ftp ws2_32 iphlpapi msvcrt kernel32)
+
 if(MSVC)
-target_link_libraries(ftp oldnames)
-add_importlibs(ftp ntdll)
+    target_link_libraries(ftp oldnames)
+    add_importlibs(ftp ntdll)
 endif()
 
-add_cab_target(ftp 1)
\ No newline at end of file
+add_cab_target(ftp 1)