[CMAKE] Get rid of the set_cpp macro
[reactos.git] / base / applications / network / telnet / CMakeLists.txt
index 8e586fa..acd2aa0 100644 (file)
@@ -1,6 +1,4 @@
 
-set_cpp(WITH_EXCEPTIONS WITH_STL)
-
 add_definitions(-D_CRT_NONSTDC_NO_DEPRECATE)
 
 if(NOT MSVC)
@@ -34,6 +32,8 @@ if(NOT MSVC)
 endif()
 
 add_executable(telnet ${SOURCE} telnet.rc)
+target_link_libraries(telnet cppstl)
+set_target_cpp_properties(telnet WITH_EXCEPTIONS)
 set_module_type(telnet win32cui)
 add_importlibs(telnet ws2_32 user32 msvcrt kernel32 ntdll)
 add_pch(telnet precomp.h SOURCE)