* Sync with recent trunk (r52637).
[reactos.git] / base / applications / winhlp32 / CMakeLists.txt
index 9acd99f..6f3b9e1 100644 (file)
@@ -1,12 +1,13 @@
 
+set_rc_compiler()
+
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
 add_definitions(
     -D__ROS_LONG64__
     -D_CRT_NONSTDC_NO_DEPRECATE
     -Dfileno=_fileno
-    -Disatty=_isatty
-    -D_DLL -D__USE_CRTIMP)
+    -Disatty=_isatty)
 
 add_executable(winhlp32
     callback.c
@@ -18,7 +19,6 @@ add_executable(winhlp32
     rsrc.rc)
 
 set_module_type(winhlp32 win32gui)
-
 target_link_libraries(winhlp32 wine)
 add_importlibs(winhlp32 user32 gdi32 shell32 comctl32 comdlg32 msvcrt kernel32 ntdll)
-add_cab_target(winhlp32 4)
+add_cd_file(TARGET winhlp32 DESTINATION reactos FOR all)