[CMAKE] Prevent out-of-bound accesses in parser/lexer files
[reactos.git] / base / applications / winhlp32 / CMakeLists.txt
index cb4ee2e..9a17ba1 100644 (file)
@@ -15,6 +15,9 @@ list(APPEND SOURCE
     winhelp.c
     precomp.h)
 
+# macro.lex.yy.c has been generated with relative file paths...
+set_source_files_properties(macro.lex.yy.c PROPERTIES COMPILE_FLAGS "-UREACTOS_SOURCE_DIR -DREACTOS_SOURCE_DIR=\"\\\".\\\"\"")
+
 add_rc_deps(rsrc.rc ${CMAKE_CURRENT_SOURCE_DIR}/res/winhelp.ico)
 add_executable(winhlp32 ${SOURCE} string.c rsrc.rc)
 set_module_type(winhlp32 win32gui)