[CMAKE]
[reactos.git] / base / applications / wordpad / CMakeLists.txt
index 6c89da0..a5817a3 100644 (file)
@@ -1,23 +1,23 @@
-list(APPEND SOURCE
-    olecallback.c
-    print.c
-    registry.c
-    wordpad.c
-    rsrc.rc)
+
+include_directories(BEFORE ${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
 add_definitions(
     -D__ROS_LONG64__
     -D_DLL -D__USE_CRTIMP)
 
-include_directories(BEFORE ${REACTOS_SOURCE_DIR}/include/reactos/wine)
-
 set_rc_compiler()
 
+list(APPEND SOURCE
+    olecallback.c
+    print.c
+    registry.c
+    wordpad.c
+    rsrc.rc)
+
 add_executable(wordpad ${SOURCE})
+
 set_module_type(wordpad win32gui)
 
 target_link_libraries(wordpad wine uuid)
-
 add_importlibs(wordpad comdlg32 ole32 shell32 user32 gdi32 advapi32 comctl32 msvcrt kernel32 ntdll)
-
-add_cab_target(wordpad 1)
\ No newline at end of file
+add_cd_file(TARGET wordpad DESTINATION reactos/system32)