* Sync up to trunk HEAD (r62285). Branch guys deserve the significant speedups too ;)
[reactos.git] / base / system / msiexec / CMakeLists.txt
index 4ae2e5f..c267c09 100644 (file)
@@ -3,12 +3,15 @@ add_definitions(-D__WINESRC__)
 
 include_directories(${REACTOS_SOURCE_DIR}/include/wine)
 
-add_executable(msiexec
+list(APPEND SOURCE
     msiexec.c
     service.c
-    rsrc.rc)
+    precomp.h)
+
+add_executable(msiexec ${SOURCE} rsrc.rc)
 
 set_module_type(msiexec win32gui)
 target_link_libraries(msiexec uuid wine)
 add_importlibs(msiexec user32 advapi32 ole32 msi msvcrt kernel32 ntdll)
+add_pch(msiexec precomp.h SOURCE)
 add_cd_file(TARGET msiexec DESTINATION reactos/system32 FOR all)