* Sync with recent trunk (r52637).
[reactos.git] / base / system / services / CMakeLists.txt
index ef34a52..162f668 100644 (file)
@@ -14,14 +14,13 @@ list(APPEND SOURCE
     services.c
     services.rc)
 
-add_executable(services ${CMAKE_CURRENT_BINARY_DIR}/services_services.h.gch ${SOURCE})
+add_executable(services ${SOURCE})
 
 target_link_libraries(services
     svcctlrpc
     ${PSEH_LIB})
 
-add_pch(services ${CMAKE_CURRENT_SOURCE_DIR}/services.h ${SOURCE})
-
 set_module_type(services win32cui)
 add_importlibs(services user32 advapi32 rpcrt4 msvcrt kernel32 ntdll)
-add_cab_target(services 1)
+add_pch(services services.h)
+add_cd_file(TARGET services DESTINATION reactos/system32 FOR all)