Replace our dxtn.dll by a version based on the libtxc_dxtn source code (#203)
[reactos.git] / dll / 3rdparty / dxtn / CMakeLists.txt
index b399df4..e2e95fb 100644 (file)
@@ -2,15 +2,10 @@
 spec2def(dxtn.dll dxtn.spec)
 
 add_library(dxtn SHARED
-    fxt1.c
-    dxtn.c
-    wrapper.c
-    texstore.c
+    txc_compress_dxtn.c
+    txc_fetch_dxtn.c
     ${CMAKE_CURRENT_BINARY_DIR}/dxtn.def)
 
 set_entrypoint(dxtn 0)
 add_importlibs(dxtn msvcrt)
-if(NOT MSVC)
-    add_target_compile_flags(dxtn "-Wno-unused-but-set-variable")
-endif()
 add_cd_file(TARGET dxtn DESTINATION reactos/system32 FOR all)