[CMAKE]
[reactos.git] / dll / ntdll / CMakeLists.txt
index 0c1adcf..77ee4c6 100644 (file)
@@ -21,10 +21,8 @@ list(APPEND SOURCE
     rtl/libsupp.c
     rtl/version.c
     def/ntdll.rc
-    def/ntdll.def)
+    ${CMAKE_CURRENT_BINARY_DIR}/ntdll.def)
     
-set_source_files_properties(def/ntdll.def PROPERTIES EXTERNAL_OBJECT TRUE)
-
 if(ARCH MATCHES i386)
 list(APPEND SOURCE dispatch/i386/dispatch.S)
 elseif(ARCH MATCHES amd64)
@@ -48,14 +46,13 @@ target_link_libraries(ntdll -Wl,--whole-archive rtl -Wl,--no-whole-archive)
 endif()
 
 target_link_libraries(ntdll
-    ${CMAKE_CURRENT_BINARY_DIR}/def/ntdll.def
                       ntdllsys
                       libcntpr
-                      pseh)
+                      ${PSEH_LIB})
                       
 add_pch(ntdll ${CMAKE_CURRENT_SOURCE_DIR}/include/ntdll.h ${SOURCE})
-add_dependencies(ntdll ntstatus)
+add_dependencies(ntdll ntstatus asm)
 
 add_minicd_target(ntdll reactos/system32 ntdll.dll)
 add_cab_target(ntdll 1)
-add_importlib_target(ntdll)
\ No newline at end of file
+add_importlib_target(def/ntdll.spec)