[CMAKE]
[reactos.git] / dll / ntdll / CMakeLists.txt
index a161f32..f2027d0 100644 (file)
@@ -1,34 +1,62 @@
 
-set(CMAKE_C_CREATE_SHARED_LIBRARY "<CMAKE_C_COMPILER> <CMAKE_SHARED_LIBRARY_C_FLAGS> <LINK_FLAGS> <CMAKE_SHARED_LIBRARY_CREATE_C_FLAGS> -o <TARGET> <OBJECTS> <LINK_LIBRARIES>")
+spec2def(ntdll.dll def/ntdll.spec)
 
-add_definitions(-D__NTDLL__)
-add_definitions(-D_NTOSKRNL_)
-add_definitions(-DCRTDLL)
+add_definitions(
+    -D__NTDLL__
+    -D_NTOSKRNL_
+    -DCRTDLL)
 
-include_directories(BEFORE ./include)
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/subsys)
+include_directories(
+    BEFORE include
+    ${REACTOS_SOURCE_DIR}/include/reactos/subsys)
 
-file(GLOB_RECURSE SOURCE *.c)
-list(REMOVE_ITEM SOURCE
-     ${CMAKE_CURRENT_SOURCE_DIR}/ldr/elf.c
-     ${CMAKE_CURRENT_SOURCE_DIR}/dispatch/dispatch.c
-     ${CMAKE_CURRENT_SOURCE_DIR}/dispatch/amd64/stubs.c)
-file(GLOB_RECURSE ARCH_SOURCE
-    "${CMAKE_CURRENT_SOURCE_DIR}/dispatch/${ARCH}/*.c"
-    "${CMAKE_CURRENT_SOURCE_DIR}/dispatch/${ARCH}/*.s")
+list(APPEND SOURCE
+    csr/api.c
+    csr/capture.c
+    csr/connect.c
+    dbg/dbgui.c
+       ldr/actctx.c
+       ldr/ldrapi.c
+       ldr/ldrinit.c
+       ldr/ldrpe.c
+       ldr/ldrutils.c
+    ldr/startup.c
+    ldr/utils.c
+    rtl/libsupp.c
+    rtl/version.c
+    def/ntdll.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/ntdll.def)
+    
+if(ARCH MATCHES i386)
+list(APPEND SOURCE dispatch/i386/dispatch.S)
+elseif(ARCH MATCHES amd64)
+list(APPEND SOURCE dispatch/amd64/stubs.c)
+elseif(ARCH MATCHES arm)
+list(APPEND SOURCE dispatch/arm/stubs_asm.s)
+else()
+list(APPEND SOURCE dispatch/dispatch.c)
+endif(ARCH MATCHES i386)
 
 add_library(ntdll SHARED
-            ${ARCH_SOURCE} ${SOURCE}
-            ${CMAKE_CURRENT_SOURCE_DIR}/def/ntdll.rc
-            ${CMAKE_CURRENT_BINARY_DIR}/ntdll_ntdll.h.gch)
+    ${CMAKE_CURRENT_BINARY_DIR}/ntdll_ntdll.h.gch
+    ${SOURCE})
 
-set_target_properties(ntdll PROPERTIES LINK_FLAGS "-Wl,-entry,0")
+set_entrypoint(ntdll 0)
 
-target_link_libraries(ntdll ${CMAKE_CURRENT_SOURCE_DIR}/def/ntdll.def
-                      -Wl,--whole-archive rtl -Wl,--no-whole-archive
+if(MSVC)
+target_link_libraries(ntdll rtl)
+else()
+target_link_libraries(ntdll -Wl,--whole-archive rtl -Wl,--no-whole-archive)
+endif()
+
+target_link_libraries(ntdll
                       ntdllsys
                       libcntpr
-                      pseh)
-                      
+                      ${PSEH_LIB})
+
+set_image_base(ntdll ${baseaddress_ntdll})
 add_pch(ntdll ${CMAKE_CURRENT_SOURCE_DIR}/include/ntdll.h ${SOURCE})
-add_dependencies(ntdll ntstatus version)
+add_dependencies(ntdll ntstatus asm)
+
+add_cd_file(TARGET ntdll DESTINATION reactos/system32 NO_CAB)
+add_importlib_target(def/ntdll.spec)