[STOBJECT] Change Turkish translation.
[reactos.git] / dll / shellext / acppage / CMakeLists.txt
index 38a2ba6..1c4c729 100644 (file)
@@ -1,3 +1,4 @@
+
 project(appcompat)
 
 set_cpp(WITH_RUNTIME)
@@ -6,6 +7,9 @@ if(NOT MSVC)
     add_compile_flags_language("-std=c++11" "CXX")
 endif()
 
+add_definitions(
+    -D_ATL_NO_EXCEPTIONS)
+
 include_directories(
     ${REACTOS_SOURCE_DIR}/sdk/lib/atl
     ${REACTOS_SOURCE_DIR}/dll/appcompat/apphelp
@@ -15,14 +19,15 @@ spec2def(acppage.dll acppage.spec ADD_IMPORTLIB)
 list(APPEND SOURCE
     ACPPage.cpp
     CLayerUIPropPage.cpp
-    CLayerUIPropPage.hpp
-    acppage.spec
-    precomp.h
-    resource.h)
+    precomp.h)
 
 add_library(acppage SHARED
     ${SOURCE}
+    acppage.spec
     ACPPage.rc
+    CLayerUIPropPage.hpp
+    CLayerStringList.hpp
+    resource.h
     ${CMAKE_CURRENT_BINARY_DIR}/acppage.def)
 
 set_module_type(acppage win32dll UNICODE)
@@ -31,4 +36,3 @@ add_delay_importlibs(acppage apphelp ole32 oleaut32 shlwapi comctl32 sfc_os)
 add_importlibs(acppage shell32 user32 advapi32 msvcrt kernel32)
 add_pch(acppage precomp.h SOURCE)
 add_cd_file(TARGET acppage DESTINATION reactos/system32 FOR all)
-