[CMAKE]
[reactos.git] / dll / shellext / devcpux / CMakeLists.txt
index 8f77431..b89c54f 100644 (file)
@@ -1,20 +1,19 @@
 
 set_unicode()
+set_rc_compiler()
 
-spec2def(devcpux ${CMAKE_CURRENT_SOURCE_DIR}/devcpux.spec ${CMAKE_CURRENT_BINARY_DIR}/devcpux.def)
+spec2def(devcpux.dll devcpux.spec)
 
-add_library(devcpux SHARED processor.c processor.rc)
+add_library(devcpux SHARED processor.c processor.rc ${CMAKE_CURRENT_BINARY_DIR}/devcpux.def)
 
 set_module_type(devcpux win32dll)
 
-target_link_libraries(devcpux ${CMAKE_CURRENT_BINARY_DIR}/devcpux.def)
-
 add_importlibs(devcpux
     user32
     powrprof
     comctl32
+    msvcrt
     kernel32
     ntdll)
 
-add_dependencies(devcpux devcpux_def)
-add_livecd_target(devcpux reactos/system32)
+add_cd_file(TARGET devcpux DESTINATION reactos/system32)