[CMAKE] Implement PCH builds with target_precompile_headers. CORE-16905
[reactos.git] / dll / shellext / shellbtrfs / CMakeLists.txt
index 7022dc0..c8fdc85 100644 (file)
@@ -24,12 +24,14 @@ list(APPEND SOURCE
     recv.cpp
     scrub.cpp
     send.cpp
-    volpropsheet.cpp
-    precomp.h)
+    volpropsheet.cpp)
+
+list(APPEND PCH_SKIP_SOURCE
+    guid.c)
 
 add_library(shellbtrfs MODULE
     ${SOURCE}
-    guid.c
+    ${PCH_SKIP_SOURCE}
     shellbtrfs.rc
     ${CMAKE_CURRENT_BINARY_DIR}/shellbtrfs.def)
 
@@ -39,5 +41,5 @@ add_rc_deps(shellbtrfs.rc ${shellbtrfs_rc_deps})
 set_module_type(shellbtrfs win32dll UNICODE)
 target_link_libraries(shellbtrfs uuid)
 add_importlibs(shellbtrfs advapi32 advapi32_vista ole32 shell32 shlwapi user32 comctl32 uxtheme setupapi comdlg32 gdi32 msvcrt kernel32_vista kernel32 ntdll)
-add_pch(shellbtrfs precomp.h SOURCE)
+add_pch(shellbtrfs precomp.h "${PCH_SKIP_SOURCE}")
 add_cd_file(TARGET shellbtrfs DESTINATION reactos/system32 FOR all)