* Sync up to trunk HEAD (r62285). Branch guys deserve the significant speedups too ;)
[reactos.git] / dll / win32 / activeds / CMakeLists.txt
index 399e654..37ae0ab 100644 (file)
@@ -6,10 +6,14 @@ spec2def(activeds.dll activeds.spec)
 list(APPEND SOURCE
     activeds_main.c
     stubs.c
+    precomp.h)
+
+add_library(activeds SHARED
+    ${SOURCE}
     ${CMAKE_CURRENT_BINARY_DIR}/activeds.def)
 
-add_library(activeds SHARED ${SOURCE})
 set_module_type(activeds win32dll)
 target_link_libraries(activeds wine)
 add_importlibs(activeds msvcrt kernel32 ntdll)
+add_pch(activeds precomp.h SOURCE)
 add_cd_file(TARGET activeds DESTINATION reactos/system32 FOR all)