Sync with trunk r58033.
[reactos.git] / dll / win32 / dbghelp / CMakeLists.txt
index 82a4ffe..d4508f6 100644 (file)
@@ -11,9 +11,6 @@ if(ARCH STREQUAL "amd64")
 endif()
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-
-set_rc_compiler()
-
 spec2def(dbghelp.dll dbghelp.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
@@ -45,9 +42,7 @@ list(APPEND SOURCE
     ${CMAKE_CURRENT_BINARY_DIR}/dbghelp_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/dbghelp.def)
 
-add_library(dbghelp SHARED
-    ${SOURCE}
-    version.rc)
+add_library(dbghelp SHARED ${SOURCE} version.rc)
 
 if(NOT MSVC)
     # FIXME: http://www.cmake.org/Bug/view.php?id=12998
@@ -60,6 +55,4 @@ target_link_libraries(dbghelp wine ${PSEH_LIB} oldnames)
 add_delay_importlibs(dbghelp version)
 add_importlibs(dbghelp psapi msvcrt kernel32 ntdll)
 add_pch(dbghelp dbghelp_private.h)
-
-
 add_cd_file(TARGET dbghelp DESTINATION reactos/system32 FOR all)