[HID] Use hidparser static library for HidP_* functions
[reactos.git] / dll / win32 / hid / CMakeLists.txt
index edc3463..1c5e6e4 100644 (file)
@@ -3,9 +3,11 @@ spec2def(hid.dll hid.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
     hid.c
-    stubs.c
     precomp.h)
 
+include_directories(
+    ${REACTOS_SOURCE_DIR}/sdk/lib/drivers/hidparser)
+
 add_library(hid MODULE
     ${SOURCE}
     hid.rc
@@ -13,5 +15,6 @@ add_library(hid MODULE
 
 set_module_type(hid win32dll UNICODE)
 add_importlibs(hid msvcrt kernel32 ntdll)
+target_link_libraries(hid hidparser_um)
 add_pch(hid precomp.h SOURCE)
 add_cd_file(TARGET hid DESTINATION reactos/system32 FOR all)