[CMAKE]
[reactos.git] / dll / win32 / httpapi / CMakeLists.txt
index 0c90507..70e942e 100644 (file)
@@ -5,12 +5,14 @@ include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
 spec2def(httpapi.dll httpapi.spec)
 
-add_library(httpapi SHARED httpapi_main.c ${CMAKE_CURRENT_BINARY_DIR}/httpapi.def)
+list(APPEND SOURCE
+    httpapi_main.c
+    ${CMAKE_CURRENT_BINARY_DIR}/httpapi_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/httpapi.def)
 
-set_module_type(httpapi win32dll)
+add_library(httpapi SHARED ${SOURCE})
 
+set_module_type(httpapi win32dll)
 target_link_libraries(httpapi wine)
-
-add_importlibs(httpapi kernel32 ntdll)
-
-add_cab_target(httpapi 1)
+add_importlibs(httpapi msvcrt kernel32 ntdll)
+add_cd_file(TARGET httpapi DESTINATION reactos/system32 FOR all)