* Sync up to trunk HEAD (r62285). Branch guys deserve the significant speedups too ;)
[reactos.git] / dll / win32 / ieframe / CMakeLists.txt
index 8101a0a..562c38d 100644 (file)
@@ -23,10 +23,13 @@ list(APPEND SOURCE
     urlhist.c
     view.c
     webbrowser.c
-    ${CMAKE_CURRENT_BINARY_DIR}/ieframe_stubs.c
-    ${CMAKE_CURRENT_BINARY_DIR}/ieframe.def)
+    ieframe.h
+    ${CMAKE_CURRENT_BINARY_DIR}/ieframe_stubs.c)
 
-add_library(ieframe SHARED ${SOURCE} ieframe.rc)
+add_library(ieframe SHARED
+    ${SOURCE}
+    ieframe.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/ieframe.def)
 
 add_typelib(ieframe_v1.idl)
 
@@ -43,4 +46,5 @@ add_dependencies(ieframe stdole2)
 set_module_type(ieframe win32dll)
 target_link_libraries(ieframe uuid wine)
 add_importlibs(ieframe urlmon shell32 comctl32 shlwapi oleaut32 ole32 user32 gdi32 advapi32 msvcrt kernel32 ntdll)
+add_pch(ieframe ieframe.h SOURCE)
 add_cd_file(TARGET ieframe DESTINATION reactos/system32 FOR all)