Sync with trunk r63502.
[reactos.git] / dll / win32 / inetcomm / CMakeLists.txt
index 34a573e..a13ee56 100644 (file)
@@ -1,37 +1,27 @@
 
 add_definitions(-D__WINESRC__)
-remove_definitions(-D_WIN32_WINNT=0x502)
-add_definitions(-D_WIN32_WINNT=0x600)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
+spec2def(inetcomm.dll inetcomm.spec ADD_IMPORTLIB)
 
-spec2def(inetcomm.dll inetcomm.spec)
-
-add_library(inetcomm SHARED
+list(APPEND SOURCE
     imaptransport.c
     inetcomm_main.c
     internettransport.c
     mimeintl.c
     mimeole.c
     pop3transport.c
-    regsvr.c
     smtptransport.c
+    inetcomm_private.h)
+
+add_library(inetcomm SHARED
+    ${SOURCE}
+    guid.c
+    inetcomm.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/inetcomm_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/inetcomm.def)
 
 set_module_type(inetcomm win32dll)
-
-target_link_libraries(inetcomm
-    uuid
-    wine)
-
-add_importlibs(inetcomm
-    ole32
-    oleaut32
-    ws2_32
-    user32
-    advapi32
-    msvcrt
-    kernel32
-    ntdll)
-
-
-add_cab_target(inetcomm 1)
+target_link_libraries(inetcomm uuid wine)
+add_importlibs(inetcomm ole32 oleaut32 ws2_32 user32 msvcrt kernel32 ntdll)
+add_pch(inetcomm inetcomm_private.h SOURCE)
+add_cd_file(TARGET inetcomm DESTINATION reactos/system32 FOR all)