Sync with trunk r63502.
[reactos.git] / dll / win32 / inetcomm / CMakeLists.txt
index 3a60d79..a13ee56 100644 (file)
@@ -1,7 +1,4 @@
 
-remove_definitions(-D_WIN32_WINNT=0x502)
-add_definitions(-D_WIN32_WINNT=0x600)
-
 add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 spec2def(inetcomm.dll inetcomm.spec ADD_IMPORTLIB)
@@ -14,22 +11,17 @@ list(APPEND SOURCE
     mimeole.c
     pop3transport.c
     smtptransport.c
+    inetcomm_private.h)
+
+add_library(inetcomm SHARED
+    ${SOURCE}
+    guid.c
     inetcomm.rc
     ${CMAKE_CURRENT_BINARY_DIR}/inetcomm_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/inetcomm.def)
 
-add_library(inetcomm SHARED ${SOURCE})
 set_module_type(inetcomm win32dll)
 target_link_libraries(inetcomm uuid wine)
-
-add_importlibs(inetcomm
-    ole32
-    oleaut32
-    ws2_32
-    user32
-    advapi32
-    msvcrt
-    kernel32
-    ntdll)
-
+add_importlibs(inetcomm ole32 oleaut32 ws2_32 user32 msvcrt kernel32 ntdll)
+add_pch(inetcomm inetcomm_private.h SOURCE)
 add_cd_file(TARGET inetcomm DESTINATION reactos/system32 FOR all)