Sync with trunk r63502.
[reactos.git] / dll / win32 / inetcomm / CMakeLists.txt
index f554549..a13ee56 100644 (file)
@@ -11,12 +11,17 @@ list(APPEND SOURCE
     mimeole.c
     pop3transport.c
     smtptransport.c
+    inetcomm_private.h)
+
+add_library(inetcomm SHARED
+    ${SOURCE}
     guid.c
+    inetcomm.rc
     ${CMAKE_CURRENT_BINARY_DIR}/inetcomm_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/inetcomm.def)
 
-add_library(inetcomm SHARED ${SOURCE} inetcomm.rc)
 set_module_type(inetcomm win32dll)
 target_link_libraries(inetcomm uuid wine)
 add_importlibs(inetcomm ole32 oleaut32 ws2_32 user32 msvcrt kernel32 ntdll)
+add_pch(inetcomm inetcomm_private.h SOURCE)
 add_cd_file(TARGET inetcomm DESTINATION reactos/system32 FOR all)