- Synchronize up to trunk's revision r57864.
[reactos.git] / dll / win32 / inetmib1 / CMakeLists.txt
index f804283..85ff339 100644 (file)
@@ -1,27 +1,23 @@
 
-add_definitions(
-    -D__WINESRC__
-    -D_DLL -D__USE_CRTIMP)
-
+add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
 spec2def(inetmib1.dll inetmib1.spec)
 
 list(APPEND SOURCE
     main.c 
+    ${CMAKE_CURRENT_BINARY_DIR}/inetmib1_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/inetmib1.def)
 
 add_library(inetmib1 SHARED ${SOURCE})
-
 set_module_type(inetmib1 win32dll)
-
 target_link_libraries(inetmib1 wine)
+add_delay_importlibs(inetmib1 iphlpapi)
 
 add_importlibs(inetmib1
     msvcrt
     snmpapi
-    iphlpapi
     kernel32
     ntdll)
 
-add_cab_target(inetmib1 1)
+add_cd_file(TARGET inetmib1 DESTINATION reactos/system32 FOR all)