[CMAKE]
[reactos.git] / dll / win32 / mapi32 / CMakeLists.txt
index 01f9054..5c1484e 100644 (file)
@@ -2,23 +2,25 @@
 add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-spec2def(mapi32 ${CMAKE_CURRENT_SOURCE_DIR}/mapi32.spec ${CMAKE_CURRENT_BINARY_DIR}/mapi32.def)
+set_rc_compiler()
 
-add_library(mapi32 SHARED
+spec2def(mapi32.dll mapi32.spec)
+
+list(APPEND SOURCE
     imalloc.c
     mapi32_main.c
     prop.c
     sendmail.c
     util.c
-    version.rc)
+    stubs.c
+    version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/mapi32_stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/mapi32.def)
 
-set_module_type(mapi32 win32dll)
+add_library(mapi32 SHARED ${SOURCE})
 
-target_link_libraries(mapi32
-    ${CMAKE_CURRENT_BINARY_DIR}/mapi32.def
-    wine
-    uuid)
+set_module_type(mapi32 win32dll)
 
-add_importlibs(mapi32 shlwapi shell32 user32 advapi32 kernel32 ntdll)
-add_dependencies(mapi32 mapi32_def)
-add_livecd_target(mapi32 reactos/system32)
+target_link_libraries(mapi32 wine uuid)
+add_importlibs(mapi32 shlwapi shell32 user32 advapi32 msvcrt kernel32 ntdll)
+add_cd_file(TARGET mapi32 DESTINATION reactos/system32 FOR all)