[CMAKE]
[reactos.git] / dll / win32 / msafd / CMakeLists.txt
index 1ab57f5..9822ad4 100644 (file)
@@ -1,10 +1,11 @@
 
 set_unicode()
 
-include_directories(BEFORE include)
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/drivers)
+include_directories(
+    BEFORE include
+    ${REACTOS_SOURCE_DIR}/include/reactos/drivers)
 
-spec2def(msafd ${CMAKE_CURRENT_SOURCE_DIR}/msafd.spec ${CMAKE_CURRENT_BINARY_DIR}/msafd.def)
+spec2def(msafd.dll msafd.spec)
 
 list(APPEND SOURCE
     msafd.rc
@@ -12,7 +13,8 @@ list(APPEND SOURCE
     misc/event.c
     misc/helpers.c
     misc/sndrcv.c
-    misc/stubs.c)
+    misc/stubs.c
+    ${CMAKE_CURRENT_BINARY_DIR}/msafd.def)
 
 add_library(msafd SHARED
     ${CMAKE_CURRENT_BINARY_DIR}/msafd_msafd.h.gch
@@ -20,10 +22,7 @@ add_library(msafd SHARED
 
 set_module_type(msafd win32dll)
 
-target_link_libraries(msafd ${CMAKE_CURRENT_BINARY_DIR}/msafd.def)
-
 add_pch(msafd ${CMAKE_CURRENT_SOURCE_DIR}/msafd.h ${SOURCE})
 
-add_importlibs(msafd advapi32 kernel32 ntdll)
-add_dependencies(msafd msafd_def)
-add_livecd_target(msafd reactos/system32)
+add_importlibs(msafd advapi32 msvcrt kernel32 ntdll)
+add_cd_file(TARGET msafd DESTINATION reactos/system32)