[CMAKE]
[reactos.git] / dll / win32 / ntmarta / CMakeLists.txt
index 19b0b84..6e98937 100644 (file)
@@ -6,18 +6,22 @@ add_definitions(-D__WINESRC__)
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
-add_library(ntmarta SHARED ntmarta.c ntmarta.rc ntmarta.def)
+spec2def(ntmarta.dll ntmarta.spec)
 
-if(NOT MSVC)
-    set_source_files_properties(ntmarta.def PROPERTIES EXTERNAL_OBJECT TRUE)
-endif()
+list(APPEND SOURCE
+    ntmarta.c
+    ntmarta.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/ntmarta.def)
+
+add_library(ntmarta SHARED ${SOURCE})
 
 set_module_type(ntmarta win32dll)
 
 add_importlibs(ntmarta
     user32
     advapi32
+    msvcrt
     kernel32
     ntdll)
 
-add_cab_target(ntmarta 1)
+add_cd_file(TARGET ntmarta DESTINATION reactos/system32 FOR all)