[CMAKE]
[reactos.git] / dll / win32 / olepro32 / CMakeLists.txt
index 7ba3421..3dda022 100644 (file)
@@ -4,18 +4,20 @@ include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
 spec2def(olepro32.dll olepro32.spec)
 
-add_library(olepro32 SHARED olepro32stubs.c version.rc
+list(APPEND SOURCE
+    olepro32stubs.c
+    version.rc
     ${CMAKE_CURRENT_BINARY_DIR}/olepro32.def)
 
+add_library(olepro32 SHARED ${SOURCE})
+
 set_entrypoint(olepro32 0)
 
-target_link_libraries(olepro32
-    wine)
+target_link_libraries(olepro32 wine)
 
 add_importlibs(olepro32
     oleaut32
     kernel32
     ntdll)
 
-
-add_cab_target(olepro32 1)
\ No newline at end of file
+add_cd_file(TARGET olepro32 DESTINATION reactos/system32 FOR all)