[CMAKE]
[reactos.git] / dll / win32 / powrprof / CMakeLists.txt
index d3ce22e..67a0619 100644 (file)
@@ -1,11 +1,12 @@
 
-set_unicode()
+spec2def(powrprof.dll powrprof.spec)
 
-add_library(powrprof SHARED powrprof.c powrprof.rc powrprof.def)
+set_unicode()
 
-if(NOT MSVC)
-    set_source_files_properties(powrprof.def PROPERTIES EXTERNAL_OBJECT TRUE)
-endif()
+add_library(powrprof SHARED
+            powrprof.c
+            powrprof.rc
+            ${CMAKE_CURRENT_BINARY_DIR}/powrprof.def)
 
 set_module_type(powrprof win32dll)
 
@@ -14,3 +15,4 @@ target_link_libraries(powrprof wine)
 add_importlibs(powrprof advapi32 user32 comctl32 kernel32 ntdll)
 
 add_cab_target(powrprof 1)
+add_importlib_target(powrprof.spec)