[CMAKE]
[reactos.git] / dll / win32 / powrprof / CMakeLists.txt
index fbfac3c..e23c882 100644 (file)
@@ -1,14 +1,17 @@
 
-set_unicode()
-
 spec2def(powrprof.dll powrprof.spec)
 
-add_library(powrprof SHARED powrprof.c powrprof.rc ${CMAKE_CURRENT_BINARY_DIR}/powrprof.def)
+set_unicode()
+
+add_library(powrprof SHARED
+    powrprof.c
+    powrprof.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/powrprof.def)
 
 set_module_type(powrprof win32dll)
 
 target_link_libraries(powrprof wine)
 
-add_importlibs(powrprof advapi32 user32 comctl32 kernel32 ntdll)
-
-add_cab_target(powrprof 1)
+add_importlibs(powrprof advapi32 user32 comctl32 msvcrt kernel32 ntdll)
+add_importlib_target(powrprof.spec)
+add_cd_file(TARGET powrprof DESTINATION reactos/system32)