Git conversion: Make reactos the root directory, move rosapps, rostests, wallpapers...
[reactos.git] / dll / win32 / psapi / CMakeLists.txt
diff --git a/dll/win32/psapi/CMakeLists.txt b/dll/win32/psapi/CMakeLists.txt
new file mode 100644 (file)
index 0000000..a58d732
--- /dev/null
@@ -0,0 +1,13 @@
+
+spec2def(psapi.dll psapi.spec ADD_IMPORTLIB)
+
+list(APPEND SOURCE
+    psapi.c
+    psapi.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/psapi.def)
+
+add_library(psapi SHARED ${SOURCE})
+set_module_type(psapi win32dll)
+target_link_libraries(psapi ${PSEH_LIB})
+add_importlibs(psapi msvcrt kernel32 ntdll)
+add_cd_file(TARGET psapi DESTINATION reactos/system32 FOR all)