[CMAKE]
[reactos.git] / dll / win32 / pstorec / CMakeLists.txt
index 053baa5..85026cf 100644 (file)
@@ -10,6 +10,7 @@ spec2def(pstorec.dll pstorec.spec)
 list(APPEND SOURCE
     pstorec.c
     rsrc.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/pstorec_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/pstorec.def)
 
 add_library(pstorec SHARED ${SOURCE})
@@ -17,5 +18,5 @@ add_library(pstorec SHARED ${SOURCE})
 set_module_type(pstorec win32dll)
 target_link_libraries(pstorec uuid wine)
 add_importlibs(pstorec msvcrt kernel32 ntdll)
-add_dependencies(pstorec pstorec_tlb pstorec_def)
-add_cab_target(pstorec 1)
+add_dependencies(pstorec pstorec_tlb)
+add_cd_file(TARGET pstorec DESTINATION reactos/system32)