[CMAKE]
[reactos.git] / dll / win32 / rsabase / CMakeLists.txt
index 89eb260..9b3f9dc 100644 (file)
@@ -2,16 +2,15 @@
 add_definitions(-D__WINESRC__)
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-spec2def(rsabase ${CMAKE_CURRENT_SOURCE_DIR}/rsabase.spec ${CMAKE_CURRENT_BINARY_DIR}/rsabase.def)
+spec2def(rsabase.dll rsabase.spec)
 
-add_library(rsabase SHARED version.rc)
+list(APPEND SOURCE
+    version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/rsabase.def)
 
-set_entrypoint(rsabase 0)
-
-target_link_libraries(rsabase
-    ${CMAKE_CURRENT_BINARY_DIR}/rsabase.def
-    wine)
+add_library(rsabase SHARED ${SOURCE})
 
+set_entrypoint(rsabase 0)
+target_link_libraries(rsabase wine)
 add_importlibs(rsabase rsaenh ntdll)
-add_dependencies(rsabase rsabase_def)
-add_livecd_target(rsabase reactos/system32)
\ No newline at end of file
+add_cd_file(TARGET rsabase DESTINATION reactos/system32)