* Sync up to trunk HEAD (r62285). Branch guys deserve the significant speedups too ;)
[reactos.git] / dll / win32 / schannel / CMakeLists.txt
index e791700..2fcfa26 100644 (file)
@@ -7,12 +7,16 @@ list(APPEND SOURCE
     lsamode.c
     schannel_main.c
     usermode.c
+    precomp.h
+    ${CMAKE_CURRENT_BINARY_DIR}/schannel_stubs.c)
+
+add_library(schannel SHARED
+    ${SOURCE}
     version.rc
-    ${CMAKE_CURRENT_BINARY_DIR}/schannel_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/schannel.def)
 
-add_library(schannel SHARED ${SOURCE})
 set_module_type(schannel win32dll)
 target_link_libraries(schannel wine)
 add_importlibs(schannel secur32 msvcrt kernel32 ntdll)
+add_pch(schannel precomp.h SOURCE)
 add_cd_file(TARGET schannel DESTINATION reactos/system32 FOR all)