[CMAKE]
[reactos.git] / dll / win32 / schannel / CMakeLists.txt
index 72e3514..37968b9 100644 (file)
@@ -1,24 +1,20 @@
 
-
-
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-
 add_definitions(-D__WINESRC__)
 
-spec2def(schannel ${CMAKE_CURRENT_SOURCE_DIR}/schannel.spec ${CMAKE_CURRENT_BINARY_DIR}/schannel.def)
+spec2def(schannel.dll schannel.spec)
 
 add_library(schannel SHARED
     lsamode.c
     schannel_main.c
     usermode.c
-    version.rc)
+    version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/schannel.def)
+
+set_module_type(schannel win32dll)
 
-set_target_properties(schannel PROPERTIES LINK_FLAGS "-Wl,-entry,_DllMain@12")
+target_link_libraries(schannel wine)
 
-target_link_libraries(schannel
-    ${CMAKE_CURRENT_BINARY_DIR}/schannel.def
-    wine
-    -lsecur32
-    mingw_common)
+add_importlibs(schannel secur32 kernel32 ntdll)
 
-add_dependencies(schannel schannel_def psdk)
+add_cab_target(schannel 1)