[CMAKE]
[reactos.git] / dll / win32 / setupapi / CMakeLists.txt
index 40e3095..0858278 100644 (file)
@@ -33,6 +33,7 @@ list(APPEND SOURCE
     stubs.c
     rpc.c
     setupapi.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/setupapi_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/setupapi.def)
 
 add_library(setupapi SHARED ${SOURCE})
@@ -40,7 +41,7 @@ add_library(setupapi SHARED ${SOURCE})
 set_module_type(setupapi win32dll)
 
 target_link_libraries(setupapi
-    pnp_client
+    pnprpc
     uuid
     wine
     ${PSEH_LIB})
@@ -58,5 +59,5 @@ add_importlibs(setupapi
     ntdll)
 
 
-add_cab_target(setupapi 1)
+add_cd_file(TARGET setupapi DESTINATION reactos/system32 FOR all)
 add_importlib_target(setupapi.spec)