[3RDPARTY] Make some warnings non-fatal
[reactos.git] / dll / win32 / shell32 / CMakeLists.txt
index 65d5f0e..60d0fc9 100644 (file)
@@ -12,6 +12,11 @@ if(NOT MSVC)
     add_compile_flags_language("-std=c++11" "CXX")
 endif()
 
+if(MSVC)
+    # error C4311: 'type cast': pointer truncation from 'HANDLE' to 'INT'
+    replace_compile_flags("/we4311" " ")
+endif()
+
 remove_definitions(-D_WIN32_WINNT=0x502)
 add_definitions(-D_WIN32_WINNT=0x600)
 
@@ -25,6 +30,8 @@ include_directories(
     ${REACTOS_SOURCE_DIR})
 
 list(APPEND SOURCE
+    CActiveDesktop.cpp
+    CActiveDesktop.h
     CIDLDataObj.cpp
     CQueryAssociations.cpp
     debughlp.cpp
@@ -84,7 +91,7 @@ file(GLOB_RECURSE shell32_rc_deps res/*.*)
 list(APPEND shell32_rc_deps ${CMAKE_CURRENT_BINARY_DIR}/shell32_shldisp.tlb)
 add_rc_deps(shell32.rc ${shell32_rc_deps})
 
-add_library(shell32 SHARED
+add_library(shell32 MODULE
     ${SOURCE}
     wine/brsfolder.c
     wine/changenotify.c