Sync with trunk.
[reactos.git] / dll / win32 / shell32 / CMakeLists.txt
index f842988..b59b679 100644 (file)
@@ -16,7 +16,7 @@ include_directories(
 spec2def(shell32.dll shell32.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
-    authors.cpp
+    #authors.cpp
     autocomplete.cpp
     brsfolder.cpp
     changenotify.cpp
@@ -54,6 +54,7 @@ list(APPEND SOURCE
     folders/fonts.cpp
     folders/cpanel.cpp
     folders/recyclebin.cpp
+    droptargets/CexeDropHandler.cpp
     shlexec.cpp
     shlfileop.cpp
     shlfolder.cpp
@@ -80,7 +81,7 @@ add_library(shell32 SHARED
     ${CMAKE_CURRENT_BINARY_DIR}/shell32_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/shell32.def)
 
-set_module_type(shell32 win32dll UNICODE)
+set_module_type(shell32 win32dll UNICODE HOTPATCHABLE)
 
 target_link_libraries(shell32
     atlnew