[CMAKE]
[reactos.git] / dll / win32 / sti / CMakeLists.txt
index 68a351c..f069fbf 100644 (file)
@@ -10,21 +10,21 @@ add_definitions(
 
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
 
-add_library(sti SHARED
+spec2def(sti.dll sti.spec)
+
+list(APPEND SOURCE
     regsvr.c
     sti.c
     sti_main.c
-    sti_wia.idl
-    sti.def)
+    ${CMAKE_CURRENT_BINARY_DIR}/sti.def)
+
+rpcproxy(sti sti_wia.idl)
 
-if(NOT MSVC)
-    set_source_files_properties(sti.def PROPERTIES EXTERNAL_OBJECT TRUE)
-endif()
+add_library(sti SHARED ${SOURCE})
 
 set_entrypoint(sti 0)
 
 target_link_libraries(sti
-    sti_proxy
     wine
     uuid
     ${PSEH_LIB})
@@ -37,5 +37,4 @@ add_importlibs(sti
     kernel32
     ntdll)
 
-rpcproxy(sti sti_wia.idl)
 add_cab_target(sti 1)