[CMAKE]
[reactos.git] / dll / win32 / ufat / CMakeLists.txt
index 9f798e1..31d1f8c 100644 (file)
@@ -1,15 +1,14 @@
 
 spec2def(ufat.dll ufat.spec)
 
-add_library(ufat SHARED
+list(APPEND SOURCE
     ufat.c
     ufat.rc
     ${CMAKE_CURRENT_BINARY_DIR}/ufat.def)
 
-set_module_type(ufat win32dll)
+add_library(ufat SHARED ${SOURCE})
 
+set_module_type(ufat win32dll)
 target_link_libraries(ufat vfatlib)
-
-add_importlibs(ufat kernel32 ntdll)
-
-add_cab_target(ufat 1)
+add_importlibs(ufat msvcrt kernel32 ntdll)
+add_cd_file(TARGET ufat DESTINATION reactos/system32)