[CMAKE]
[reactos.git] / dll / win32 / ufat / CMakeLists.txt
index d1e5f94..9f798e1 100644 (file)
@@ -1,14 +1,15 @@
 
-spec2def(ufat ${CMAKE_CURRENT_SOURCE_DIR}/ufat.spec ${CMAKE_CURRENT_BINARY_DIR}/ufat.def)
+spec2def(ufat.dll ufat.spec)
 
-add_library(ufat SHARED ufat.c ufat.rc)
+add_library(ufat SHARED
+    ufat.c
+    ufat.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/ufat.def)
 
 set_module_type(ufat win32dll)
 
-target_link_libraries(ufat
-    ${CMAKE_CURRENT_BINARY_DIR}/ufat.def
-    vfatlib)
+target_link_libraries(ufat vfatlib)
 
 add_importlibs(ufat kernel32 ntdll)
-add_dependencies(ufat ufat_def)
-add_livecd_target(ufat reactos/system32)
+
+add_cab_target(ufat 1)