[CMAKE]
[reactos.git] / dll / win32 / uxtheme / CMakeLists.txt
index 548125d..f0b8e85 100644 (file)
@@ -1,11 +1,8 @@
 
-
-
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/wine)
-
 add_definitions(-D__WINESRC__)
 
-spec2def(uxtheme ${CMAKE_CURRENT_SOURCE_DIR}/uxtheme.spec ${CMAKE_CURRENT_BINARY_DIR}/uxtheme.def)
+spec2def(uxtheme.dll uxtheme.spec)
 
 add_library(uxtheme SHARED
     buffer.c
@@ -17,17 +14,13 @@ add_library(uxtheme SHARED
     stylemap.c
     system.c
     uxini.c
-    version.rc)
+    version.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/uxtheme.def)
+
+set_module_type(uxtheme win32dll)
 
-set_target_properties(uxtheme PROPERTIES LINK_FLAGS "-Wl,-entry,_DllMain@12")
+target_link_libraries(uxtheme wine)
 
-target_link_libraries(uxtheme
-    ${CMAKE_CURRENT_BINARY_DIR}/uxtheme.def
-    wine
-    -luser32
-    -ladvapi32
-    -lgdi32
-    -lmsimg32
-    mingw_common)
+add_importlibs(uxtheme user32 advapi32 gdi32 msimg32 kernel32 ntdll)
 
-add_dependencies(uxtheme uxtheme_def psdk)
+add_cab_target(uxtheme 1)