[CMAKE]
[reactos.git] / dll / win32 / ws2help / CMakeLists.txt
index 5c0dea3..51f0c99 100644 (file)
@@ -1,9 +1,9 @@
 
-spec2def(ws2help.dll ws2help.spec)
-
 include_directories(${REACTOS_SOURCE_DIR}/include/reactos/winsock)
 
-add_library(ws2help SHARED
+spec2def(ws2help.dll ws2help.spec)
+
+list(APPEND SOURCE
     apc.c
     context.c
     dllmain.c
@@ -11,9 +11,9 @@ add_library(ws2help SHARED
     notify.c
     ${CMAKE_CURRENT_BINARY_DIR}/ws2help.def)
 
-set_module_type(ws2help win32dll)
-
-add_importlibs(ws2help advapi32 ws2_32 kernel32 ntdll)
+add_library(ws2help SHARED ${SOURCE})
 
-add_cab_target(ws2help 1)
+set_module_type(ws2help win32dll)
+add_importlibs(ws2help advapi32 ws2_32 msvcrt kernel32 ntdll)
+add_cd_file(TARGET ws2help DESTINATION reactos/system32)
 add_importlib_target(ws2help.spec)