[CMAKE]
[reactos.git] / dll / win32 / wshtcpip / CMakeLists.txt
index 4aded70..1f1664f 100644 (file)
@@ -1,15 +1,20 @@
 
+set_unicode()
+
 include_directories(${REACTOS_SOURCE_DIR}/lib/tdilib)
 
-spec2def(wshtcpip ${CMAKE_CURRENT_SOURCE_DIR}/wshtcpip.spec ${CMAKE_CURRENT_BINARY_DIR}/wshtcpip.def)
+spec2def(wshtcpip.dll wshtcpip.spec)
 
-add_library(wshtcpip SHARED wshtcpip.c wshtcpip.rc)
+list(APPEND SOURCE
+    wshtcpip.c
+    wshtcpip.rc
+    ${CMAKE_CURRENT_BINARY_DIR}/wshtcpip.def)
 
-set_module_type(wshtcpip win32dll)
+add_library(wshtcpip SHARED ${SOURCE})
 
-target_link_libraries(wshtcpip
-    ${CMAKE_CURRENT_BINARY_DIR}/wshtcpip.def
-    tdilib)
+set_entrypoint(wshtcpip 0)
 
-add_importlibs(wshtcpip ntdll ws2_32)
-add_dependencies(wshtcpip wshtcpip_def psdk)
+target_link_libraries(wshtcpip tdilib)
+add_importlibs(wshtcpip ws2_32 kernel32 ntdll)
+add_dependencies(wshtcpip psdk)
+add_cd_file(TARGET wshtcpip DESTINATION reactos/system32)