[CMAKE]
[reactos.git] / dll / win32 / xmllite / CMakeLists.txt
index d28ff83..a1b14a8 100644 (file)
@@ -7,15 +7,16 @@ spec2def(xmllite.dll xmllite.spec)
 list(APPEND SOURCE
     reader.c
     xmllite_main.c
+    #${REACTOS_BINARY_DIR}/include/psdk/xmllite_i.c
+    ${CMAKE_CURRENT_BINARY_DIR}/xmllite_stubs.c
     ${CMAKE_CURRENT_BINARY_DIR}/xmllite.def)
 
 add_library(xmllite SHARED ${SOURCE})
 
 set_module_type(xmllite win32dll)
 
-target_link_libraries(xmllite
-    wine)
+target_link_libraries(xmllite wine uuid)
 
 add_importlibs(xmllite msvcrt kernel32 ntdll)
-
-add_cab_target(xmllite 1)
+add_importlib_target(xmllite.spec)
+add_cd_file(TARGET xmllite DESTINATION reactos/system32)