[CMAKE] Implement PCH builds with target_precompile_headers. CORE-16905
[reactos.git] / drivers / usb / usbstor / CMakeLists.txt
index 567ee54..eaaee54 100644 (file)
@@ -11,16 +11,18 @@ list(APPEND SOURCE
     queue.c
     error.c
     scsi.c
-    usbstor.c
-    usbstor.h)
+    usbstor.c)
+
+list(APPEND PCH_SKIP_SOURCE
+    guid.c)
 
 add_library(usbstor MODULE
     ${SOURCE}
-    guid.c
+    ${PCH_SKIP_SOURCE}
     usbstor.rc)
 
 set_module_type(usbstor kernelmodedriver)
 add_importlibs(usbstor ntoskrnl hal usbd)
-add_pch(usbstor usbstor.h SOURCE)
+add_pch(usbstor usbstor.h "${PCH_SKIP_SOURCE}")
 add_cd_file(TARGET usbstor DESTINATION reactos/system32/drivers NO_CAB FOR all)
 add_driver_inf(usbstor usbstor.inf)