[HAL] Implement amd64 BIOS call support
[reactos.git] / hal / halx86 / CMakeLists.txt
index 8311314..f4148eb 100644 (file)
@@ -5,7 +5,8 @@ add_definitions(
 
 include_directories(
     include
-    ${REACTOS_SOURCE_DIR}/ntoskrnl/include)
+    ${REACTOS_SOURCE_DIR}/ntoskrnl/include
+    ${REACTOS_SOURCE_DIR}/sdk/include/reactos/libs/fast486)
 
 function(add_hal _halname)
     cmake_parse_arguments(_haldata "" "" "SOURCES;COMPONENTS" ${ARGN})
@@ -76,5 +77,6 @@ elseif(ARCH STREQUAL "amd64")
         amd64/processor.c)
 
     add_hal(hal SOURCES ${HAL_SOURCE} COMPONENTS generic acpi apic)
+    target_link_libraries(hal fast486)
 
 endif()