[CMAKE]
[reactos.git] / lib / 3rdparty / bzip2 / CMakeLists.txt
index 880174c..1c609ff 100644 (file)
@@ -1,6 +1,6 @@
 add_definitions(-DBZ_NO_STDIO -DBZ_DECOMPRESS_ONLY)
 
-spec2def(bzip2 ${CMAKE_CURRENT_SOURCE_DIR}/unbzip2.spec ${CMAKE_CURRENT_BINARY_DIR}/unbzip2.def)
+spec2def(bzip2 unbzip2.spec)
 
 list(APPEND SOURCE
     bzlib.c
@@ -8,14 +8,13 @@ list(APPEND SOURCE
     crctable.c
     decompress.c
     huffman.c
-    dllmain.c)
+    dllmain.c
+    ${CMAKE_CURRENT_BINARY_DIR}/unbzip2.def)
 
 add_library(bzip2 SHARED ${SOURCE})
 
 set_target_properties(bzip2 PROPERTIES LINK_FLAGS "-Wl,-entry,_DriverEntry@8 -Wl,--image-base,0x00010000 -Wl,--subsystem,native" OUTPUT_NAME "unbzip2")
 
-target_link_libraries(bzip2 ${CMAKE_CURRENT_BINARY_DIR}/unbzip2.def)
-
 add_importlibs(bzip2 ntoskrnl)
 
-add_dependencies(bzip2 bzip2_def bugcodes)
\ No newline at end of file
+add_dependencies(bzip2 bugcodes)
\ No newline at end of file