[CMAKE]
[reactos.git] / lib / rossym / CMakeLists.txt
index 2efce18..5462fb4 100644 (file)
@@ -1,4 +1,15 @@
 
-file(GLOB_RECURSE SOURCE "*.c")
-
-add_library(rossym ${SOURCE})
\ No newline at end of file
+add_definitions(-D_NTSYSTEM_)
+list(APPEND SOURCE
+    delete.c
+    find.c
+    fromfile.c
+    frommem.c
+    fromraw.c
+    getraw.c
+    init.c
+    initkm.c
+    initum.c
+    zwfile.c)
+add_library(rossym ${SOURCE})
+add_dependencies(rossym psdk)
\ No newline at end of file